Wadjet Eye Games

Author Topic: Mac: Crash when scaling the wall with Matthius / DirectDraw/Direct3D problem  (Read 6991 times)


  • Guest
Hi there, just bought the game a few hours ago. Ran fine so far with Direct3D. DirectDraw worked kinda horrible in fullscreen mode - it just flickered madly between the game and whatever else I had on my screen.
For some reason, it crashed every time after Matthius jumped over the wall - the game hung up, sound kept repeating until finally the error message of Windows came around and told me that Gemini Rue had to be closed. However, it did work with DirectDraw (still horribly flickering in full screen), so I had to get Matthius over in DirectDraw. Then I saved and tried to play in Direct3D again, but then I couldn't load - "Error: mismatched colour depths" is the error message I got in a little window with Adventure Game Studio in the title.
Now I got to play it in windowed mode with DirectDraw. Still can't load the old files with Direct3D, but I can load everything with DirectDraw.
Works for now, I guess. Has anyone else encountered that problem?
« Last Edit: May 13, 2013, 02:35:52 AM by Jericho »

Offline superluser

  • Newbie
  • *
  • Posts: 16
    • View Profile
What emulation software and version are you using?  Which version of Windows is it emulating?

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2521
    • View Profile
If this is the GOG.com version you are using, they made the Mac version themselves so I'm afraid I don't know much about it! You will have to ask them.

Offline dpeif717

  • Newbie
  • *
  • Posts: 1
    • View Profile
I've experienced this problem with the GOG mac port. I contacted their support and within a day or two they replied suggesting switching the renderer, like OP did, scaling the wall, then saving. Like OP says though, you're unable to load that save with a Direct3D after saving it in DirectDraw, which is a downside.

I had some flickering with DirectDraw in the beginning so I switched to Direct3D and the game ran fine up until this glitch. After the switching/saving, I've actually lost the cmd + F fullscreen capability, and I'm forced to play the game at 1280 x 800 now.

I give GOG credit for providing the support although that first suggestion didn't help. They also provided a save game file to try, I'm not sure which renderer it's using though because I haven't been able to load it yet. I can't attach it here because it's not an allowed file type but GOG will send it if you contact them.