Wadjet Eye Games

Author Topic: Bad Performance, Lag  (Read 5383 times)

Offline gymsox

  • Newbie
  • *
  • Posts: 3
    • View Profile
Bad Performance, Lag
« on: December 17, 2013, 08:55:03 AM »
Hi.
Sadly, I have terrible performance with Primordia. there's a slight pause everytime game assets are loaded, as in hovering over a hotspot, loading dialog, etc. plus The game stutters every few seconds, freezing animations and sound.
There are no hardlocks or crashes yet, and sometimes it seems to catch itself and run fine for some minutes. Blackwell has caused no problems whatsoever and I guess it's the same engine.
I verified the game data (Steam), redownloaded, checked drivers etc and am now at a loss.

Please advise

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Bad Performance, Lag
« Reply #1 on: December 17, 2013, 12:37:44 PM »
Hm. If you have no trouble with Blackwell, I'm wondering what the issue could be. Primordia is a lot more asset-heavy than most of our games, but it still shouldn't be an issue. Could you list your system specs? Maybe that could help shed some light!


Offline gymsox

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Bad Performance, Lag
« Reply #2 on: December 18, 2013, 05:47:05 AM »

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Bad Performance, Lag
« Reply #3 on: December 18, 2013, 10:10:50 AM »
OK, here's a stab in the dark. I see you use Vista. When this problem came up in the Vista days, changing the graphics driver to DirectDraw sometimes fixed it. Here's how to do it via the Steam client:

- right click on the game in your Steam library
- Select "properties"
- Select "Set launch options"
- type "--setup"
- hit OK
- Launch game!

The game will launch the setup window before launching the game. From here you will see a dropdown menu labelled "graphics driver" which is set to Direct3D. Set it to DirectDraw and run the game. On more recent computers, Direct3D is the better choice which is why it is set that way by default. Occasionally, the reverse is true. Let me know if it works.

-Dave

Offline gymsox

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Bad Performance, Lag
« Reply #4 on: December 18, 2013, 12:54:31 PM »
Whaddaya know, that did it. Awesome :D
Thanks a lot <3

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Bad Performance, Lag
« Reply #5 on: December 18, 2013, 01:11:40 PM »
<phew. it worked.>

Offline RPGCoder

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Bad Performance, Lag
« Reply #6 on: December 31, 2013, 09:41:49 PM »
I ran across this issue today when I installed the game for the first time. Changing to DirectDraw didn't fix the issue, unfortunately, but I eventually worked out the problem. The hitches I was getting were always occurring when a sound effect or VO played (footsteps, mouse-over events on some menu items, etc.). I had installed the game on an external USB 3.0 Western Digital MyBook hard drive, and despite being fairly speedy the on-demand loading of audio assets seems to have performance problems when passing through that bus. I reinstalled the game on my small solid state drive and everything worked fine.

Offline MarkYohalem

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Wormwood Studios
Re: Bad Performance, Lag
« Reply #7 on: January 01, 2014, 10:26:35 AM »
Interesting.  Thanks for the tip -- never would've thought that could be the problem!

And Happy New Year!
Wormwood Studios
Writer / Designer on Primordia