Wadjet Eye Games

Author Topic: Choppy walking animations  (Read 10305 times)

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Choppy walking animations
« Reply #15 on: December 12, 2012, 01:10:28 PM »
Hi guys. Sorry for the delay in hopping on this thread. It's hard to keep up with all the forum posts these days! In future, it's always faster to email us directly with questions instead of posting or PMing.

This seems like an AGS engine compatibility issue (AGS being the engine we used to create the game) rather than a game scripting issue, which is a bit beyond our area of expertise. By best advice would be to go to the AGS technical forum and explain the situation there. I hate to pass the buck, as it were, but it will be much quicker for you to explain your situation to them directly as opposed to me acting as a go-between. The techies on that forum are much more knowledgeable about how the engine works on different computer setups than we do, and so are in a much better position to help you.

And once they do help you, please post the solution here so we can help others with the same problem!

Thanks and sorry again for these issues,

-Dave
« Last Edit: December 12, 2012, 01:20:18 PM by DaveGilbert »

Offline gorzek

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Choppy walking animations
« Reply #16 on: December 12, 2012, 03:33:21 PM »
To register on the AGS forums I have to answer 15 extremely patronizing questions. That's very nice.

They don't seem very friendly. They'll probably just close the thread and tell us to post in the Wadget Eye forums.

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Choppy walking animations
« Reply #17 on: December 12, 2012, 04:08:18 PM »
Yeesh, really? They must have updated the forums there. It never used to be that way. Hm. I'll try posting there and tell them to look over here! :)

Edit: Aha - I see you've posted already. The thread is HERE, if anyone wants to see it. If a solution is found, I'll be sure to repost it here.
« Last Edit: December 12, 2012, 04:11:10 PM by DaveGilbert »

Offline Aphantas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #18 on: December 14, 2012, 02:19:27 AM »
Post repeated on the AGS Forum
--------- Poster - Aphantas, December 14th
I think I have found a solution to this problem!
It is a environmental-related problem, which seems to be related to Anti-Virus Programs.
I was running AVG Anti-Virus 2013 while the game was running, and disabling this program has resulted in smooth game-play.
I am not sure if this extends to other Anti-Virus Programs.

@Gorzek: Thanks for finding that it may be an environment issue, however my solution implies that you should check your Anti-Virus status immediately.
Running a full scan may be a good idea as well. 
--------
I have been able to replicate this solution reliably on my own computer at least.

Offline Winged Hussar

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Choppy walking animations
« Reply #19 on: December 14, 2012, 10:36:14 AM »
A huge thanks to Aphantas. I am also using AVG Anti-Virus and disabling it fixed the problem with choppy animations. Now everything runs smoothly.

Offline MarkYohalem

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Wormwood Studios
Re: Choppy walking animations
« Reply #20 on: December 14, 2012, 11:29:40 AM »
Great work guys.  Thanks for resolving this issue!  I've cross-posted on Steam and GOG.
Wormwood Studios
Writer / Designer on Primordia

Offline AstonPrimordia

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy walking animations
« Reply #21 on: December 15, 2012, 06:14:35 PM »
Fantastic, works for me too! Very excited to finally get to play the game!

Offline djblackskull

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #22 on: December 15, 2012, 11:42:53 PM »
this didn't resolve the issue for me. the demo didn't have this audio issue at all. i'm using the direct link version(gog version did it as well). i've played with all the game's settings which actually made things worse. it seems more of an audio buffer or audio back buffer issue. when walking around whatever audio happens to be playing at the time, as well as whatever triggered second audio sound effect plays will cause both and all audio to sort of skip back a 1/4th of a second. this is a dual core i3 processor on the particular laptop i am using. 4gigs of ram, intel hd graphics, intel hd audio.

Offline MarkYohalem

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Wormwood Studios
Re: Choppy walking animations
« Reply #23 on: December 16, 2012, 03:12:38 AM »
Could be somehow related to the footsteps, but they were in the demo.  I can't think of any audio changes that took place between demo and release.
Wormwood Studios
Writer / Designer on Primordia

Offline djblackskull

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #24 on: December 18, 2012, 06:55:39 PM »
i have other computers i can play this on, so for me it's not that big of a deal.. i've played it on 3 diff computers and i only see it on the i3. for whatever reason it does exist. i can record a video if you like.. it would probably speak a bit more about what i'm seeing rather than trying to simulate an idea through text.

Offline MarkYohalem

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Wormwood Studios
Re: Choppy walking animations
« Reply #25 on: December 18, 2012, 07:42:33 PM »
I certainly won't object to you doing a video to help us resolve the issue!  You certainly aren't obliged to, but we'd appreciate it.
Wormwood Studios
Writer / Designer on Primordia