Wadjet Eye Games

Author Topic: Choppy walking animations  (Read 10238 times)

Offline AstonPrimordia

  • Newbie
  • *
  • Posts: 7
    • View Profile
Choppy walking animations
« on: December 05, 2012, 09:27:44 PM »
Hello,

I just bought Primordia on Steam, and was just now trying it for the first time. Unfortunately the animations for Horatio's walking are choppy, to a degree that it is really annoying. To see if it wasn't supposed to be like that I checked a "Let's play" on youtube (https://www.youtube.com/watch?v=Ys30I9rZAb4). They don't seem to have that problem at all, and it looks smoother overall. I'm not sure if it's just the walking animation that is choppy, or other animations as well, as I only played the first few screens of the game.

Specs:
Windows 7 64-bit
Intel Core 2 Duo E7500
Radeon HD 4850
4 GiB RAM

I have experimented a little bit with the winsetup.exe for Primordia, but without any improvements. Any idea what i can do to make it run smooth?

Regards,
Anton

Offline Aphantas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #1 on: December 06, 2012, 07:59:21 PM »
I have the same issue. However the walking animation only slows down when the footstep sound plays. It makes it seem quite odd as he moves forward a step, stops, then continues.
I also thought that it was an intentional effect until I noticed that the whole game was slowing down at that time as well, rain, Crispin etc.
My Computer Specs are

Op System: Windows 7 (64-bit)
CPU: Pentium(R) Dual Core CPU E5700 (3GHz)
Video Card: AMD Radeon HD 6870
Ram: 4 Gb


Offline AstonPrimordia

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy walking animations
« Reply #2 on: December 07, 2012, 04:18:23 PM »
That does indeed sound like the problem I'm having. And I still haven't got it to work.

Someone please assist us! I really want to play the game, but it's pretty much unenjoyable like this.

Offline DaveGilbert

  • Administrator
  • Hero Member
  • *****
  • Posts: 2215
    • View Profile
Re: Choppy walking animations
« Reply #3 on: December 07, 2012, 08:55:11 PM »
Hmm. Have you guys tried playing it in windowed mode to see if it improves at all? Or switching from direct3d to directdraw?

Offline Aphantas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #4 on: December 08, 2012, 01:34:24 AM »
Yep, I have tried DirectDraw and windowed mode, as well as them both at once.
I also tried disabling the digital sound, but that causes the game to crash at start-up, as i detailed in another thread. 
thanks for the response

Offline Winged Hussar

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Choppy walking animations
« Reply #5 on: December 08, 2012, 08:21:47 AM »
I am using a GOG version and I have the same problem. I've tried every setting possible but it changes nothing (and on occasion even makes things worse). All of the previous Wadjeteye games (Shivah, Blackwell series, Gemini Rue, Resonance) worked perfectly on my computer. I would be very grateful if someone could find a solution to this problem.

Offline Aphantas

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #6 on: December 08, 2012, 08:37:22 AM »
Just for Clarification, I am too using a GOG version of the game.

Offline AstonPrimordia

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy walking animations
« Reply #7 on: December 09, 2012, 04:06:25 PM »
I'm playing the Steam version. I have tried the things mentioned above (windowed etc).

Offline djblackskull

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Choppy walking animations
« Reply #8 on: December 10, 2012, 04:41:11 AM »
the tearing of sprites was both in the demo/full version of this game. there is an option in options/advanced to increase the buffer.. it helps a bit, but not much.

Offline AstonPrimordia

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Choppy walking animations
« Reply #9 on: December 11, 2012, 06:44:36 PM »
the tearing of sprites was both in the demo/full version of this game. there is an option in options/advanced to increase the buffer.. it helps a bit, but not much.

Yes, I tried that but I didn't get any noticeable improvement.

Offline gorzek

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Choppy walking animations
« Reply #10 on: December 11, 2012, 09:36:56 PM »
This is also happening to me. It's very unfortunate, but the game is unplayable as it is. I don't mean to be rude, but it's just too annoying to tolerate.
Everything just freezes for a split second when the following sounds play:
a) Horatio's footsteps
b) Main menu, hover-on and hover-off of a button
c) Probably others

I also tried everything I could try (every possible combination) in winsetup.exe. Windowed, antialias, nearest neighbor, every combination of sound/music drivers, all the checkboxes. I do mean everything. Also DD/D3D. Buffer size to all possible sizes. Nothing helps. I also tried running the game with administrator permission. I even tried disabling Steam Community for the game (so the overlay doesn't pop up).

Steam Version
Win7 64 bits
4 GB RAM
GTX 260
Core 2 Duo E7200
« Last Edit: December 11, 2012, 09:42:46 PM by gorzek »

Offline goldeng

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Choppy walking animations
« Reply #11 on: December 12, 2012, 01:04:02 AM »
Hi everyone,

I see that most of you are having the issue when playing the Stream and GOG versions of the game. It could be the Steam/GOG client settings or something that causes the issue... Did anyone encountered the issue with the demo version that available for download from Wadjet Eye Games? http://www.wadjeteyegames.com/primordia.html

djblackskull mentioned that he encountered the issue with both the demo and full versions of the game. Was the demo from the link above or from Steam/GOG? I'm just not that familiar if there is a demo from these platforms.

By the way, no one has mentioned what is the value that appears under the 'Maximum Size' of MB  that the game uses under the 'Advanced >>>' section at the Game's settings. I'm not sure how you reach that section in Steam/GOG but at the regular version you could reach the settings by running the 'winsetup.exe' from the game's directory. The 'Advanced >>>' button is on the lower right hand of the dialog box. Basically the default value should be 20 MB. But you can never know if changing that value might solve the issue.
Regards,
Gal Shemesh

Offline gorzek

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Choppy walking animations
« Reply #12 on: December 12, 2012, 07:23:23 AM »

By the way, no one has mentioned what is the value that appears under the 'Maximum Size' of MB  that the game uses under the 'Advanced >>>' section at the Game's settings. I'm not sure how you reach that section in Steam/GOG but at the regular version you could reach the settings by running the 'winsetup.exe' from the game's directory. The 'Advanced >>>' button is on the lower right hand of the dialog box. Basically the default value should be 20 MB. But you can never know if changing that value might solve the issue.

We have mentioned it quite a bit. Three times, in fact!

I quote:

Quote from: djblackskull
there is an option in options/advanced to increase the buffer.. it helps a bit, but not much.

Quote from: AstonPrimordia
Yes, I tried that but I didn't get any noticeable improvement.

Quote from: gorzek
Buffer size to all possible sizes

So we do, in fact, know that it doesn't help.

Offline Hanky_Pank

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Choppy walking animations
« Reply #13 on: December 12, 2012, 12:00:18 PM »
Beautiful game, ruined by this choppy walk animation. SLows all the surrounding animations down whenever Horatio walks, destroying the whole experience.

Real shame, haven't played a good sci-fi adventure game in ages and this started as a fantastic experience. But this choppiness makes it unplayable.

Offline MarkYohalem

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
    • Wormwood Studios
Re: Choppy walking animations
« Reply #14 on: December 12, 2012, 12:49:38 PM »
Hanky (and others): We're obviously very distressed to hear about this issue, and we're doing everything we can to diagnose it.  Are you using Steam, GOG, or a direct download from WEG?  What OS, and what type of mouse?  This is all kind of shooting in the dark, but maybe we can figure something out.

Perhaps this is related:
http://steamcommunity.com/app/227000/discussions/0/846938351165531384/#p2

But I've seen this complaint on the GOG boards as well, so there are obviously other things triggering it.  One thing that I've heard is that if you have precision clicking enabled on a Logitech mouse, that can cause slowdown (but typically related to the pointer).  Another thing to try -- although it sounds like you guys have tried everything -- would be switching from D3D mode to DDraw mode and trying different filters.

I say all of this with the caveats (1) I'm not the coder, I'm the writer; (2) I don't know much about AGS (the engine used for this); and (3) without more specifics, it'll be hard to debug.  But we're certainly eager to work with you guys to resolve this, or at least to not leave you hanging after you supported our game.
Wormwood Studios
Writer / Designer on Primordia