Wadjet Eye Games Community Forum

Wadjet Eye Games => The Blackwell series => Topic started by: bamcrashkapow on July 29, 2017, 12:45:11 AM

Title: Epiphany keeps crashing?
Post by: bamcrashkapow on July 29, 2017, 12:45:11 AM
Hey, all. I'm on my second playthrough of Epiphany, this time with commentary. I've just finished my first conversation with Kendra in her house. Every time I try to progress the story from here, the game will crash and give me the same error message:

"---------------------------
Illegal exception
---------------------------
An exception 0xC0000005 occurred in ACWIN.EXE at EIP = 0x0050594B ; program pointer is +5, ACI version 3.21.1115, gtags (48,1)

AGS cannot continue, this exception was fatal. Please note down the numbers above, remember what you were doing at the time and post the details on the AGS Technical Forum.

in "GUIportrait.asc", line 233
from "room21.asc", line 127


Most versions of Windows allow you to press Ctrl+C now to copy this entire message to the clipboard for easy reporting.

An error file CrashInfo.dmp has been created. You may be asked to upload this file when reporting this problem on the AGS Forums. (code 0)"

It occurs at the exact same point in conversation between Joey and Rosa after he comes out of the house to talk to her, when Joey mentions that they've "seen some pretty nasty stuff". I'm not too sure what to do to fix this... Has anyone else encountered this? Any ideas how to fix this?
Title: Re: Epiphany keeps crashing?
Post by: DaveGilbert on August 07, 2017, 01:22:48 PM
I looked at the code, and I can't see any reason why that is happening. Or if it is happening, I can't see why why it has not happened to anybody else.

That said, it appears that that line is triggered when you play as Joey and you LEAVE the Haskins house while Rosa is outside. You can avoid that line triggering by simply switching to Rosa and then leaving the area. Joey will follow automatically and the line won't be triggered.

I will look into the error in the meantime!
Title: Re: Epiphany keeps crashing?
Post by: bamcrashkapow on August 07, 2017, 06:18:36 PM
The bypass worked perfectly - thanks Dave! It was really strange, particularly because I've played through the game and this part already in the past and been fine. I figure it's something on my end if no one else has experienced it, maybe a file got corrupted and an uninstall/reinstall will fix it? But this bypass works for now :) Thanks again!