Wadjet Eye Games Community Forum

Wadjet Eye Games => Primordia => Topic started by: DemosS13 on May 22, 2017, 10:48:41 AM

Title: Crash on Startup
Post by: DemosS13 on May 22, 2017, 10:48:41 AM
I tried to launch Primordia through Steam and from the local files folder, both have the same results.

First error, before game launches.

Unable to initialize your audio hardware.
[Problem: Failed to init MIDI music driver]

Click OK

Blank screen fill, a couple seconds later, second error appears.

An error has occurred. Please contact the game author for support, as this is likely to be a scripting error and not a bug in AGS.
(ACI version 3.21.1115)

in "NewCommands.asc", line 3097
from "room27.asc", line 158

Error: Error running function 'room_Load':
Error: Null pointer referenced

End of error messages.

Included: DxDiag output for system information.

Edit: The number of views since topic creation tells me either I'm not the only one having this issue or crawler bots count for views, as well. In the interest of getting this resolved or someone having a working solution/workaround to this issue, here's some more information.

Verifying integrity does not solve the issue.
Running as administrator does not solve the issue.
Editing any/all of the launch options does not solve the issue.

If you are experiencing the exact same issue as I am, my recommendation is to add your dxdiag output .txt file and any attempted fixes you have tried in a reply to this thread. Registering to post and help would be well worth the effort if it results in a solution. Perhaps with enough data or input, someone can find a workaround or the devs can be coaxed to hotfix this. I'm rather eager to play this game, despite the age, and I know the devs are likely busy with other projects, but I remain hopeful that this title will one day work for me.
Title: Re: Crash on Startup
Post by: MarkYohalem on May 25, 2017, 12:18:04 AM
We are ever vigilant, though sometimes a little slow on this forum, in customer care! :D  I'm confident we can get this fixed.  Give me a minute to comb through past bug fixes.
Title: Re: Crash on Startup
Post by: MarkYohalem on May 25, 2017, 12:21:19 AM
First let's try this to deal with the sound issue: http://www.adventuregamestudio.co.uk/forums/index.php?topic=33311.0

Title: Re: Crash on Startup
Post by: MarkYohalem on May 25, 2017, 12:22:18 AM
Switching support over to the Steam thread you started, since more eyes see stuff there:
http://steamcommunity.com/app/227000/discussions/0/1291817208485521549/
Title: Re: Crash on Startup
Post by: DemosS13 on May 25, 2017, 02:42:06 AM
The advice given on Steam did the trick.

The issue boiled down to me not having any midi support (how? why? Who knows!) but once I installed a midi synth and got one to play, the game started without issues!

Thanks again for the help! I hope this topic (or the one on Steam) can help others to launch and enjoy this game, without the hassle of thinking they have midi support and believing there's a bigger issue than missing that file support!