Wadjet Eye Games Community Forum

Wadjet Eye Games => Technobabylon => Topic started by: johnwwells on February 25, 2017, 08:07:36 PM

Title: Bug? (Grenade problem; spoilers]
Post by: johnwwells on February 25, 2017, 08:07:36 PM
I've been enjoying Technobabylon a lot, but I've hit an impasse near the end.


In the end, there's a puzzle where you load a grenade into a drone, and then move it into position - either via a stopped turbine or a set of lifts. However, the grenade never detonates for me, regardless of which solution I try. Instead, I get the message that the drone was eaten up by machinery.

I've followed walkthroughs, but is there something I'm missing? I move the drone up into the entrance area of the room with Latha, have either Lao or Regis click the grenade on the drone, am told that the pin was pulled and the grenade placed in the drone's storage area, and then I either:

* Stop the turbine and move the drone across the still shaft and up behind the left side of the screen, when I receive the message that's been eaten up by the machinery.


* I move it across the elevator platforms, and again am told the same.

I tried reloading an earlier save from the beginning of the chapter and restarting, but no dice - it doesn't seem to recognize that a grenade was placed on the drone. Is there some special way to set the grenade that I'm missing, and that doesn't seem to be in walkthroughs? Or is this a bug?
Title: Re: Bug? (Grenade problem; spoilers]
Post by: tocy777 on March 17, 2017, 09:25:38 AM
I just registered to say this that YES, I am experiencing the same problem.
The grenade countdown is not starting after Regis puts it into the drone...

PLS fix :'(
Title: Re: Bug? (Grenade problem; spoilers]
Post by: Technocrat on March 27, 2017, 03:39:07 PM
Hello! I've not seen this one before, but I'll take a dig around in the guts of the game to see if I can identify the problem.

Just want to check, have you also allowed the grenade to count down without it being in the machinery? And if so, what happened to the drone?
Title: Re: Bug? (Grenade problem; spoilers]
Post by: tocy777 on March 27, 2017, 03:48:37 PM
The countdown doesn't starts, after the grenade is placed it is gone from the invertory and has no effect, I can record it if that helps :)
Title: Re: Bug? (Grenade problem; spoilers]
Post by: Technocrat on March 27, 2017, 04:29:02 PM
It might do! If possible, could you upload a save game from there as well?
Title: Re: Bug? (Grenade problem; spoilers]
Post by: locke456 on July 04, 2017, 05:00:32 PM
Was a solution ever found for this bug? I've run into the exact same problem, and am crushed that it seems like I'm not going to be able to finish this great game so close to the end...

I would upload my save file, but it exceeds the size limit for attachments.
Title: Re: Bug? (Grenade problem; spoilers]
Post by: Moerges on August 24, 2017, 06:41:55 PM
Hello there.

A friend of mine just ran into this very problem, and after some tinkering, we figured out what causes it, and how to avoid it. To save others who experience this issue the frustration, I decided to register here and post the solution.

Apparently, the grenade timer breaks when Latha exits the camera view at any point during the drone/grenade process. To get the grenade to blow up, make sure to switch to Lao/Regis without clicking ›Disconnect from camera‹ first; simply open the inventory while Latha is still looking at the camera feed and switch to Lao/Regis from there.

Just to make sure, here's the step by step rundown:

1. pick up the Grenade with Lao or Regis and enter the Turbine Room
2. open the inventory and switch to Latha
3. enter the camera feed with Latha, deploy the Drone and move it next to Lao/Regis
4. without ever clicking ›Disconnect from camera‹, open the inventory and switch to Lao/Regis
5. open the inventory and have Lao/Regis use the Grenade on the Drone
6. open the inventory and switch to Latha

If everything is working as it is supposed to, you should now see a countdown timer next to the ›Drone‹ label—which means that the Drone is loaded and ready to either incapacitate or kill the Mindjacker.

If you saved the game after loading the Grenade onto the Drone, simply go and pick up another Grenade from the Dead Body outside the Turbine Room; he's got an infinite supply. Then perform the above steps.

We've tried this on two different computers, and both breaking the countdown and getting it to work are reproducible on both.

Hope this helps anyone else who has trouble with it.