Wadjet Eye Games Community Forum

Wadjet Eye Games => Primordia => Topic started by: kanrup on December 08, 2016, 03:05:41 PM

Title: great
Post by: kanrup on December 08, 2016, 03:05:41 PM
hey makers of Primordia, hope ur still alive.

sadly steam did not activate my later Steam achievements for some reason. :(

got through to an ending without resorting to a walkthrough. quite smug about that heh. puzzles were challenging but sometimes hints saved me. no hints for the console puzzle tho was quite hard to figure that one out.

this game also made me laugh a few times. Crispins quite funny.

really enjoyed playing this game. very captivating story. beautiful art and music too.
just wish there was 1 more map to explore. miss this game already.

any thoughts on making another one? I'm waiting
like the sad robot at the bus stop :(
Title: Re: great
Post by: MarkYohalem on December 09, 2016, 12:34:17 AM
Hey!  Thanks for the kind post!

Which achievements did you miss?  It's possible that you missed something along the way, though it could also be a glitch.

I'm very pleased you didn't use a walkthrough! That was the dream when James (the coder) and I spent a bajillion hours making Crispin's hints work. You might be the only person it actually saved. (Balancing the console puzzle has been the bane of my existence.)

In hindsight, I too think we should've had another area (probably the Cathedral, and you'd end up there after the Clarity vs. Scraper fight, and working your way from top to bottom and then through the subway tunnel back to the Main Street station).

We're almost certainly not gonna make another game in the setting, but we will make other games -- we're working on an RPG right now, and in parallel another adventure game.  There's also this short story in the setting: primordia-game.com/fallen.html

Anyway, thanks again so much for playing the game and sharing your reaction.
Title: Re: great
Post by: kanrup on December 09, 2016, 03:30:39 PM

I went to the very end, doing things like looking at all coordinates for telescope, training Crispin for the date, and chose live free or die ending. (sad ending. but I like to think Horatio ninjaed out at the very end, chopped off Scrapers other arm with his damn welder and proceeded to generally wreck the whole place.)

but I only have 2 badges unlocked. I guess it is a glitch.

Im sad there may not be another but I guess its nice for Primordia to be a one off. that way the essence of the story and world may be concentrated.  meanwhile some games just dont know when to stop >.> (still think Primordia setting would make a very thematic comic book)

Ill be reading the fallen these days. looks good. also like the extra crispin log and Primer poem.
Hey speaking of Crispin he reminded me of the yellow floaty bot from "Flubber" film. hardly remember that film. except the bot dying. :/

also I read somewhere in utube that guy who voiced Horatio is the same as the storyteller from Bastion. is that right?
Title: Re: great
Post by: MarkYohalem on December 11, 2016, 11:53:07 PM
Yep, Logan Cunningham voiced both.

That's odd about your achievements -- I'm not sure why they wouldn't unlock. There are various achievement walkthroughs that might help, not sure though.

I've actually never seen Flubber.  I feel like the irreverent floating sidekick has been around forever -- Orko, Iago, Cedric, Zzyzzx, Morte, etc.  Morte (from Planescape Torment) was my closest inspiration.
Title: Re: great
Post by: kanrup on January 01, 2017, 10:30:32 AM
If it helps I've thought of a few places I got stuck in:

> at first was stuck for a while at the Unique, the light was out and cant get in. noticed the lamp
but didnt actually realise I could use crispin on the lamp. Later I was also stuck for a long while
near live electric wire near the burning bus. was trying all kinds of thing but for some reason
I had not thought of just using crispin on wire.

> at the giant robot in dunes (goliath?) was stuck for a while trying to block the remaining nose
hole. had tried to take the cloth from pole before but after it blew away in wind, did not chase after
it and try to find it. so after that I forgot about the cloth until I tried everything on giants nose.

> was stuck before getting to the head of giant. did not realise I could ask crispin to tie cable to
top floor.

> at the (?gamma) screens inside giant, because there is a slight change in screen when gamma
moves to it, I was trying to keep up with the fase change of screen brightness. that didnt help
because gamma doesnt stop and when crispin says
there has to be a better way I think I did use energy sensor on screen. but it said its detecting energy
so I thought that was no help. In end I used plasma torch on screen and the puzzle was ruined.

> was stuck trying to find code to communicate with factor. tried all kinds of numbers
but never thought about talking to brother of the round robot (lawrence?).
After a long while stuck, got a hint that round robots brother may know code.
then spent a long time going over and over the lower city area. actually looked at a few of clarity's heads
stuck on poles, but still missed lawrence head. I think the head may have been too small and
blended in too well with other heads.
after another long while stuck got another hint from two followers prettymuch giving place where
head will be.

> obtained monocole of memorius, but after a while forgot who glass was from. in end was
randomly using glass on things everywhere, and using it on info console worked in end. a log of
what round robot said may have been useful.
didnt actually know info booth was linked to memorius until after clarity said something.

> start of console puzzle. didnt think to enter misspelled word until after crispin pointed it out.
after this you get couple of odd lines. it was not obvious if this info was just a statement about
what has happened (thought it was just a statement that metromind has taken over).
after going away from console and being stuck a long while came back to
this screen.was entering things almost at random when the answer was entered.
after that crispin comments and confirms there is a puzzle here.

> because the console mentions redline mispelled and also way to 'cathedral' is via blueline,
I spent a lot of time going around station area Horatio enters city from. trying to find a way to
cathedral, as console also mentions steeple mainframe is in cathedral. thought the clue to
steeple was at cathedral (not at the vendor). Also because there is an actual sign called
blueline, so I was doing all sorts like using monocole on sign. did notice the railway map because
of this though.

> though I spoke to the robot at bomb before, I did not note the name was leobuilt. so I did not
make a connection that Horatio's book should be given to vendor. a hint helped me here later.
maybe a character profile screen or a  conversation log may have been useful?

> a conversation log might have helped at the riddle of the two rex robots near courthose. they
shoot it out very fast.
Title: Re: great
Post by: MarkYohalem on January 03, 2017, 12:23:05 AM
Thanks! This is really valuable -- though it's too late to fix anything with Primordia, it's good to know for future games where people got stuck in the past, so we can avoid similar problems.